Make your own free website on Tripod.com

Trabajo de Algoritmos (ESTRUCTURAS REPETITIVAS)

 

1.- Corregir los siguientes algoritmos

     buscar todo error posible.

 

2.- Realizar un ejercicio parecido a cada ejercicio

por ejemplo  un ejercicio parecido al nro1 seria: hacer un programa que muestre los múltiplos de 5 comprendidos entre 600 y 400 en orden descendente.

 

 

Ejercicio Nº 1

Hacer un programa que muestre los múltiplos de 5 comprendidos entre 200-300 *** iniciar el contador en 200

 

Inicio

  Leer “Número”, N

  X=200

  Mientras X<=300 Hacer

     Escribir X

     X=X+5

  Fin Mientras

Fin

 

Ejercicio Nº 2

Calcular el acumulado de las edades de un grupo de N personas siempre y cuando dichas  edades sean mayores a 18 y no pasen los 45.

Inicio

  Leer “Número De Personas”, N

  A = 0

  X = 1

  Mientras x<=N hacer

    Leer “Edad”, E

    Si E>18 y E<45 hacer

      A=A+E

    Fin si

    X=X+1

  Fin mientras

 Escribir A

Fin

 

Ejercicio Nº3

Calcular el promedio de las edades de un grupo de N personas siempre y cuando dichas edades sean menores a 20  y sean mayores 55.

 

Inicio

  Leer “Nùmero De Personas”, N

  H = 0

  M = 1

  O = 1

  Mientras O< = N hacer

    Leer “Edad”, D

    Si D<20  o  D>45 hacer

      H=H+D

      M=M+1

     Fin si

     O=O+1

  Fin mientras

  Prom =  H / M

 Escribir Prom

Fin

 

 

Ejercicio Nº 4

Hacer un programa que muestre los números pares entre 1000 y 0, pero no escribirá los números que se encuentren en el  rango de 200 A 50.

Inicio

  X=1000

  Mientras x>0 hacer

     X=x-2

     Si x<200 o x>50

       Escribir x

     Fin si

  Fin mientras

Fin 

 

Ejercicio Nº 5

Hacer un programa que en cada vuelta vaya mostrando los acumulados de los números pares entre 1000 y 0, pero no escribirá los números cuando el contador se encuentra entre el  rango de 200 a 50.

Inicio

  X=1000

  B=0

  Mientras X>0 hacer

  X=x+2

  B=B+X

  Si x<200 o x>50

     Escribir B

  Fin si

  Fin mientras

Fin

 

 

Ejercicio Nº6

Dados n números, construir un algoritmo que determine la suma de los que sean mayores a cero, el producto de los menores que cero y cuántos son iguales a cero. (use un solo bucle)

Inicio

  Leer “Número”, N

  A = 0

  P = 0

  N = 0

 Mientras N>0 hacer

   Leer Número

   Si Número = 0 entonces 

      N=N+1

      Si Número >0 entonces

        A= A + Número

         Si no

         Si Número >0 entonces

          A= A+ Número

          Si no

 

 

 

 

    P=P*Número

   Fin si

  Fin si

    N=N-1

Fin mientras

Escribir A, P, N

Fin

        

Ejercicio Nª 7

Si ingresamos los datos (base, altura)  y también los lados (a, b, c) de 35 triángulos, calcular cuántas áreas son pares, cuantas impares, cuantas no se pudieron calcular por no existir el triangulo.

Inicio

  P=0

  I=0

  N=0

  X=35

  Mientras x>0 hacer

     Leer a, b, c, h, b

     Si a-b <c y a-c <b y b-c< a entonces

        Si a+b>c y a+c>by b+c>a entonces

           Área = (H*B)/2

           Si (area mod 2)=0 hacer

               P=P+1

             Si no

               I=I+1

            Fin si

           Si no

           N=N+1

         Fin si

       Si no

          N=N+1

      Fin si

       X= X - 1

    Fin mientras

    Escribir P, I, N, A

Fin 

 

Ejercicio Nª 8

En el ejercicio anterior se desea conocer cual fue el de mayor área.

Inicio

  A=0

  P=0

  I=0

  N=0

  X=35

  Mientras x>0 hacer

     Leer a, b, c, H, B

     Si a-b <c y a-c <b y b-c< a entonces

        Si a+b>c y a+c>by b+c>a entonces

           Área = (H*B)/2

     Si area>A entonces

               A= Area

              Fin si           

            Fin si

          Si no

           n=n+1

         Fin si

       Si no

          n=n+1

      Fin si

       X= x - 1

    Fin mientras

    Escribir A

Fin

 

Ejercicio Nª 9

En el ejercicio 7 se desea conocer cual fue el de menor área.

Inicio

  A=0

  P=0

  I=0

  N=0

  X=35

  Mientras x>0 hacer

     Leer a, b, c, H, B

     Si a-b <c y a-c <b y b-c< a entonces

        Si a+b>c y a+c>by b+c>a entonces

           Área = (H*B)/2

           Si x=35 entonces

                 A=area

               Si no

                Si area>A entonces

                   A= Area

                Fin si

           Si no

           n=n+1

         Fin si

       Si no

          n=n+1

      Fin si

       X= x - 1

    Fin mientras

    Escribir  A

Fin 

 

Ejercicio Nª 10

En el ejercicio 7 suponga que no son 35 triángulos la cantidad queda determinada cuando la persona que maneja el programa decida en una de las vueltas terminar el bucle INGRESANDO una altura de -1 (menos uno) en ese instante ella desea conocer:

 

1.- Cuantos triángulos ingresó 2.- Cuantos fueron validos  3.- Cuantos son equiláteros 4.- Cuantos son isósceles.

 

Inicio

 

N = 0

V= 0

C = 0

I = 0

SW = 0

 

Mientras SW = 0  hacer

            Leer a, b, c, H, B

            Si H<>-1 entonces

                        N = N+1   

             Si a-b <c y a-c <b y b-c< a entonces

            Si a+b>c y a+c>by b+c>a entonces

                        V=V+1

                        SI NO

                        Si a=b y a=c entonces

                                               C=C+1

                        Si no

                        Si a=b o a=c o b=c entonces

            I=I+1                  

            Fin si           

                        Fin si

                                   Fin si

                        FIN SI

            Si no

            SW=1

            Fin si

Fin mientras

 

Escribir N, V, C, I

 

Fin 

 

Ejercicio Nª 11

 

Hacer un programa que lea 350 consumos de un restaurante. Si el consumo ingresado al computador excede los 200 soles, el descuento es del 15%. Muestre todos los pagos efectuados y el acumulado de todos estos pagos.

Inicio

  X=350

  A=0

  Mientras x>0 entonces

    X=x-1

    Leer C

    Si C > 200 Entonces

      C=C*0.85

    Fin si

    a=a+c

   Escribir C

  Fin mientras

  Escribir a

Fin

 

Ejercicio Nª 12

En el ejercicio anterior considere que de los 350,  10 consumos fueron gratuitos debido a una política del restaurante que dice que cada 35 clientes 1 es gratis, así las posiciones 35, 70, 105… son gratis. El dueño desea saber lo siguiente:

            - Cuanto dinero se dejo de ganar por consumos gratis

            - Que porcentaje representa los consumos gratis respecto a los no gratis

            - Que numero de cliente fue el que se vio mas favorecido según el orden de llegada

            - Que numero de cliente fue el consumió y pagó más.

            - ¿La suma de los 10 primeros consumos representa mas dinero que los 10 últimos?

 

Inicio

X=0

ACG=0

ACNG=0

CB=0

NCB=0

NCCM=0

NCCM=0

NCPM=0

CCM=0

CPM=0

SP=0

SU=0

Mientras x < 350 hacer

  X=x+1

  Leer C

  Si c>ccm entonces

    Ccm=c

    Nccm=x

   Fin si

   Si C>200 entonces

      C=C*0.85

    Fin si

   Si x < 11 entonces

     Sp=sp+c

     Si no

     Si x>340 entonces

      Su=Su+C

     Fin si

    Fin si

   Si (xmod35) = 0 entonces

   Acg=acg+c

  Si C>CB entonces

    CB = C

    NCB=X

  Fin si

Si no

Acng=Acng +C

Si C>cpm entonces

 CPM=C

 NCPM=X

Fin si

Fin si

Fin mientras

Escribir acg

P=(acg*100)/acmg                                           

Escribir ncb

Escribir nccm

Escribir ncpm

Si sp>su entonces

   Escribir “La suma de los 10 primeros      consumos representa mas dinero que los 10 últimos”

  Si no

    Escribir “La suma de los 10 últimos consumos representa mas dinero que los 10 primeros”

  Fin si

Fin

  

Ejercicio Nª 13

Un aula tiene 50 estudiantes de algoritmos, el profesor a cada estudiante le toma 10 prácticas, 2 exámenes y 3 trabajos. El promedio de las prácticas representan el 50% de la nota del curso,    el Prom. De los 2 exámenes el 40%, y el    promedio de  los trabajos el 10%.

Se desea saber:

-          Cuantos pasan con promedio 20, cuantos con promedio 18 cuantos con promedio 16.

-          Cuantos aprueban el curso y cuantos desaprueban

-          Cual fue la mínima nota

-          Cuantos tienen un promedio menor a 8

-          Cuantos tienen trabajos desaprobados

   I nicio

   X=50

   A20=0

   A18=0

   A16=0

   Apro=0

   Desap=0

   Nm=0

   Pm8=0

   Td=0

   Pp=0

   Pt=0

   Pe=0

   Pf=0

   Mientras x<50 hacer

   Leer p1,p2, p3, p4, p5, p6, p7, p8, p9, p10,e1, e2, t1, t2, t3

   pp=(p1+p2+p3+p4+p5+p6+p7+p8+p9+p10)/10

      Pt=(t1+t2+t3)/3

      Pe= (e1+e2)/2

      Pf= 0.5*pp + 0.4*pe + 0.1 * pt

      Según sea pf entonces

        20:a20=a20+1

        18:a18=a18+1

        16:a16=a16+1

        Si no: Si  pf <8 entonces

          Pm8=pm8+1

        Fin si

        Si pf>=14 entonces

         Apro=apro+1

         sino

         desp=desp+1

       Fin si

       Si ti<14 ot2<14ot3<14 entonces

         Td=td+1

       Fin si

   Si x=1 entonces

     Nm=pf

     Si no

       Si pf<nm entonces

        Nm=pf

       Fin si

    Fin si

  Fin mientras

 Escribir A20,  A18,  A16, APRo, Desa,

 m=0,  Pm8,   Td,  Pp,  P,  Pe,  Pf

 Fin

 

 

Ejercicio Nª14

Suponiendo que y es la función de t :

Y:2t²-T²-15T+40

Escriba un programa en el que publique el “y” que corresponda a cada t desde -5 hasta 5. En pasos de 0.25 y encuentre el mínimo y el máximo de los valores calculados de y 

Inicio

  T=-5

  Max = 2*t^2-t^2-15*t+40

 Mientras t<=5 hacer

    Y=2*t^2-t^2-15*t+36

     Escriba t, y

     Si max<y

       Max=y

       Si no

        y<min

        Min =Y

      Fin si

      T=T+0.25

  Fin mientras

  Escribir Min, Max

Fin

 

       

 

Ejercicio Nº 15

Cada  registro en el  archivo de estudiantes contiene, el peso de cada estudiante. El cual deber ser menor o igual Hacer un programa que encuentre el peso promedio de los estudiantes.

Inicio  

  Suma =0

  N=0

  p=23

  Desde p>= 23 hacer

   Suma = Suma + Peso

   N= N + 1

 Hasta N>50

Promedio=Suma/N

Escribir Promedio

Fin

 

Ejercicio Nº 16

Detección datos numéricas –  erróneas.

Esta Subrutina sencilla  consiste en hacer un programa en el que un Instituto que se viene de otro país hace un doble  análisis   de Nº de alumnados. Esta haciendo su matricula  nos pida  ingresar al computador un cierto tipo de alumnados pero con la condición de que estos sean menores o iguales a 13 escribir no se da el curso si no escribir si se da el curso.  

Inicio

Sw = 2

 Mientras sw = 2

  Leer "alumnado", d

    Si d <= 13 entonces

     Escribir "no se da el curso"

     Si no

     Escribir "se da el curso", C

     Sw = 3

    Fin si

 Fin mientras

Sw = 3

 Mientras sw = 3 hacer

Leer "alumnado", d

    Si d <= 13 entonces

     Escribir "no se da el curso"

     Si no

     Escribir "se da el curso", C

    Sw = 4

   Fin si

 Fin mientras

Fin

 

Ejercicio Nº 17

Se dispone de un  cierto números de valores de los cuales el ultimo es el 1999(no se procesa: es final de lista) y se

desea determinar el valor máximo de las medidas correspondientes a parejas de valores sucesivos.

 

Inicio

Leer N1, N2

Max =(N1+N2)/2

 Mientras N2<>1999 Y N1<>1999 hacer

  M=(N1+N2)/2

   Si m>max entonces

    Max =n

   Fin si

   Leer N1, N2

 Fin mientras

 Escribir”media máxima=”, max

Fin

 

Ejercicio Nº 18

Calcular la media aritmética de una serie

Indeterminada de números

Inicio

P=0

Suma=0

Leer a

Mientras a<>FF hacer

  P=P+1

  Suma=Suma +a

  Leer a

Fin mientras

 Media =Suma/P

 Escribir “El total de números”, N

 Escribir “La media es=”, media

Fin

 

Ejercicio Nº 19

Hacer un programa que muestre   la calificación más alta  de  2 salones. También debe mostrarse la calificación mas alta de cada salón, si se sabe que cada salón, si se   cuanta con 35 alumnos.

Inicio

Calificación x = 0

Calificación y = 0

I=1

Mientras i<=35 hacer

 Leer n

 Si n> calificación x entonces

   Calificación x =n

 Fin si

 I=i+1

Fin _ mientras

Escribir “calificación x”

I=1

Mientras i<=35 hacer

Leer n

Si n< calificación y entonces

 Calificación y=n

Fin si

I=i+1

Fin mientras

Escribir “calificación y”

Si calificación x> calificación y

   Escribir “calificación x”

 Sino

 Escribir “calificación y”

Fin si

Fin

 

Ejercicio Nª 20

Hacer un algoritmo que clasifique 98 personas según la comida que consume

Inicio

Leer Comida consumida

Desde x=1 hasta 98 hacer

 Si  Comida consumida = C peruana  entonces

       C peruana  = C peruana  +1

 Fin si

Si  Comida consumida= C argentina entonces

       C argentina= C argentina+1

    Fin si

Si Comida consumida= C Boliviana entonces

       C Boliviana = C Boliviana +1

    Fin si

Si Comida consumida= C Italiana entonces

       C Italiana = C Italiana +1

    Fin si

Si Comida consumida= C Francesa entonces

       C Francesa = C Francesa +1

    Fin si

 

 Escribir “equivocado”

 

Fin desde

Escribir “C peruana”,” C argentina”,” C Boliviana”, “C Francesa”

Fin