Make your own free website on Tripod.com

Estructuras de control selectivas

La clase de hoy será para ampliar un poquito mas sobre estructuras de selección, pero básicamente desarrollaremos muchos ejercicios en clase
a fin de estar expeditos para la práctica.

de ahora en adelante las prácticas que se tomen serán con respecto a la clase anterior, o sea este Jueves 16 tomaremos lo aprendido el Jueves 9

 

Se usan cuando se presentan varios CASOS  por ejemplo un Menú  de computadora tiene varios Casos u opciones
así el menú Archivo presenta los CASOS Abrir, Guardar, Guardar como, Imprimir

Entonces, SEGUN lo que valga la variable opción, elegiremos una alternativa de entre todas las posibles.

La forma de escribir esto en pseudocódigo es:

 SEGUN SEA la variable o la expresión HACER
       VALOR1: {las acciones que toque}
        ...
       VALORN: {las acciones que toque}
       por defecto: {las acciones que toque}
 fin_SEGUN 

¿Qué pinta ahí ese 'por defecto'?

No es más que una alternativa por si acaso se elige alguna opción no contemplada entre las que se ofrece.

Como ejemplo, vamos a ver nuestro menú utilizando la alternativa múltiple SEGUN SEA:

 inicio
   escribir 'menu de opciones'
   escribir '1. Diccionario de sinonimos'
   escribir '2. Diccionario de antonimos'
   escribir '3. Buscar palabra'
   escribir '4. Salir'
   leer opción

   SEGUN SEA opción HACER
         opción = 1 : {lo que toque a esta opción}
         opción = 2 : {lo que toque a esta opción}
         opción = 3 : {lo que toque a esta opción}
         opción = 4 : {lo que toque a esta opción}
         por defecto: {mostrar un posible mensaje de error}
   FIN _ SEGÚN
 fin

Así queda mucho más claro, no sólo para nosotros, si no para cualquier persona que tuviera que leerlo; además, es una forma más sencilla de manejar una alternativa múltiple. 

Podemos abreviar un poquito el texto; es igualmente válido poner, dentro del SEGUN, lo siguiente:

   SEGUN SEA opcion HACER:
         1 : {lo que toque a esta opcion}
         2 : {lo que toque a esta opcion}
         3 : {lo que toque a esta opcion}
         4 : {lo que toque a esta opcion}
         por defecto: {mostrar un posible mensaje de error}
   fin SEGUN 

 


Me quedan las estructuras repetitivas, que las veremos en la próxima entrega, si no esto puede ser mucho trago de golpe O:)

En cualquier caso, ya teneis cosas para ir empezando a pensar en la escritura de algoritmos. Yo sugiero los siguientes...

EJERCICIOS

  1. Escribir un algoritmo que calcule el área de un triángulo siempre que sea un triangulo valido.
  2. Escribir un algoritmo que calcule el área de un rectángulo siempre que un lado sea mayor que otro.
  3. Escribir un algoritmo que calcule el área de un trapecio siempre que la base superior sea menor a la inferior.
  4. Escribir un algoritmo que calcule el precio de un artículo tras aplicarle un 19% de IGV y preguntar si el producto está exonerado de impuestos
  5. Escribir un algoritmo que intercambie el contenido de dos variables, siempre que sean diferentes.
  1. Escribir un algoritmo que resuelva una ecuación de segundo grado, teniendo en cuenta todas las posibles alternativas.
  2. Diseñar un esquema de menú de opciones, por ejemplo, un menú para seleccionar un libro a leer de entre siete disponibles.
  3. Escribir un algoritmo que lea tres números e imprima por pantalla el mayor de ellos.
  4. Escribir un algoritmo que lea tres números e imprima por pantalla el menor de ellos.

Tarea:

Esta ves buscaremos páginas de Internet donde existan clases de PROGRAMACIÓN ESTRUCTURADA.

1.- ALCANZAR AL MENOS 6 DIRECCIONES DONDE ENCUENTRE CLASES SOBRE ESTRUCTURAS DE CONTROL CON SI-ENTONCES-FIN_SI  Y SELECCIÓN MÚLTIPLE CON SEGUN SEA.

2.- Los alumnos me han enviado muchos ejercicios pues ahora alcanzo el enlace BAJAR EJERCICIOS para que se bajen los ejercicios y corrijan al menos 6 ejercicios de ellos. Al menos decir las fallas del ejercicio original.

Toma de Asistencia para esta clase, el que no marca no tendrá notas:

Apellidos y Nombres del Alumno  
E-mail del alumno                         
Código USAT                             

Suerte.