Make your own free website on Tripod.com

Estructuras Repetitivas (Bucles)

 

Un bucle o lazo (Loop)  es un segmento de un algoritmo o programa, cuya instrucciones se repiten un número determinado de veces mientras se cumple una determinada condición (existe o es verdadera la condición). SE debe establecer un mecanismo para determinar las tareas repetitivas. Este mecanismo es una condición que puede ser verdadera o falsa y que se comprueba una vez a cada paso o iteración del bucle (total de instrucciones que se repiten en el bucle).

Un bucle consta de tres partes:

El bucle de la siguiente figura  es infinito, ya que las instrucciones (1), (2) y (3) se ejecutan indefinidamente, pues no existe salida del bucle, al no cumplirse una determinada condición.

 

 

 

Si tras la lectura de la variable N se coloca una condición, el bucle dejará de ser infinito y tendrá fin cuando la condición sea verdadera.

 

El diagrama de flujo escrito en pseudo código es aproximadamente el siguiente:

Inicio

    SUMA 0

    1: leer N

    Si N = 0 entonces

        Escribir SUMA

        Ir_a fin

    Si_no

        Suma suma + N

    FIN_SI

    IR_A 1

FIN

 

 

BUCLES ANIDADOS

Un bucle puede anidarse dentro de otro como se vio en clase con los condicionales anidados (un si fin_si dentro de otro si Fin_si)

 

Contadores

 

Un contador es una variable cuyo valor se incrementa o decremento en una cantidad constante en cada vuelta.

La siguiente figura 

contar del 1 al 50

 

presenta un diagrama de flujo para un algoritmo que se desea repetir 50 veces; el contador se representa en este ejemplo con la variable CONT. La instrucción que representa a un contador es la asignación CONT = CONT + 1.

La siguiente figura

 

Decrementar desde N hasta 0

 

es otro ejemplo de un diagrama de flujo con contador; es este caso, negativo. Se dice también descontar.

El contador puede ser positivo (incrementos, uno en uno) o negativo (decrementos, uno en uno).

 

Importante acerca de incrementos y decrementos:

En la primera Figura el contador cuenta desde 1 al 50 y deja de contar cuando la variable CONT toma el valor 51 y se termina el bucle.

 

En la segunda Figura el contador cuenta negativamente, o lo que es lo mismo, descuenta o decrementa; comienza a contar en n y se decrementando hasta llegar a cero, en cuyo caso se termina el bucle y se realiza la acción escribir.

 

Como se vio anteriormente la condición permite terminar el bucle cuando ésta es verdadera (si) 

ahora veremos las estructuras repetitivas que se usarán en el curso de algoritmos:

 

Tipos de estructuras repetitivas

 

Mientras Condicion Hacer

Fin_mientras

 

Desde Variable=inicio  Hasta Variable=Final  hacer

Fin_desde

 

(La anterior también puede ser usada con la palabra PARA en vez de DESDE ejemplo:

    PARA Variable=inicio  Hasta Variable=Final  hacer

    Fin_PARA)

 

Repetir

Hasta Condicion

Hemos visto que las Estructura repetitivas son aquellas en las que especialmente se diseña para todas aquellas

aplicaciones en las cuales una operación o conjunto de ellas deben repetirse muchas veces.

asi los Bucles (lazos o LOOPs) Son estructuras que repiten una secuencia de instrucciones un numero determinado de veces.

 

Interacción: Es el hecho de repetir la ejecución de una secuencia de acciones; en otras palabras el algoritmo repite muchas veces las acciones.

 

Al utilizar un bucle para sumar una lista de números, se necesita saber cuantos números se han de sumar, para poder detenerlo en el momento preciso; las dos principales preguntas ha realizarse en el diseño de un bucle son:

¿Que contiene el bucle? y ¿Cuántas veces se debe repetir?

 

Casos Generales de Estructuras repetitivas

1) La condición de Salida del bucle se realiza al principio del bucle (estructura mientras) también llamada PRE-CONDICIONAL

2) La condición de Salida se origina al final del bucle; el bucle se verifica hasta que se verifique una cierta condición

también llamada POST-CONDICIONAL (estructura Repetir Hasta).

3) La condición de salida se realiza con un contador que cuente el numero de interacciones. ( i es un contador que cuenta desde el valor inicial (vi.) hasta el valor final (vf) con los incrementos que se consideren.) (estructura DESDE o PARA)

 

Estructura mientras ("while")

Es aquella en que el cuerpo del bucle se repite mientras se cumple una determinada condición. Cuando se ejecuta la acción  mientras, la primera cosa que sucede es que se evalúa la condición (una expresión booleana que devuelve Verdadero o Falso), si se evalúa falsa ninguna acción se tomara y el programa en la siguiente instrucción del bucle; si la expresión booleana es verdadera, entonces se ejecuta el cuerpo del bucle, depuse del cual se evalúa de nuevo la expresión booleana.

Esta expresión booleana se repite una y otra vez mientras la expresión booleana (condición) sea verdadera

 

Estructura repetir ("repeat").

Si el valor de la expresión booleana es inicialmente falso, el cuerpo del Bucle no se ejecutara, por ello se necesitan de otros tipos de estructuras. Dicha estructura se ejecuta hasta que cumpla una condición determinada que se comprueba hasta el final del bucle

 

Diferencias entre las estructuras mientras y repetir

Estructura desde/para ("for").

Son el numero total de veces que se desea ejecutar las acciones del Bucle (numero de interacciones fijo), este ejecuta las acciones del cuerpo o del Bucle un numero especifico de veces y de modo automático controla el numero de Interacciones o pasos a través del cuerpo del bucle.

 

Ejemplos con Mientras

 

Forma de Uso

 

Mientras condicion hacer

            acción 1

            acción 2

            acción 3

            ....

            acción n

Fin_Mientras

 

1.- Hacer un programa que cuente del uno al 10

 

Inicio

    x= 1

    Mientras x<=10 hacer

        Escribir x

        x= x + 1

    Fin_Mientras

Final

 

2.- Hacer un Programa que  pida un número y muestre los 10 siguientes números  a el.

 

Inicio

    leer x

    Parada = x + 10

    Mientras x<=Parada hacer

        Escribir x

        x =  x + 1

    Fin_Mientras

Final

 

3.- Hacer un programa que cuente del 20 a 1 en forma descendente

 

Inicio

    x= 20

    Mientras x>=1 hacer

        Escribir x

        x = x - 1

    Fin_Mientras

Final

 

4.- Realizar un algoritmo que muestre por pantalla la tabla de multiplicar del número DOS en forma decreciente..
 

INICIO
        n = 2
        x = 12
        mientras x >= 1 hacer
                R <- n * x
                Escribir x, n, R
                x =- x - 1
        fin_mientras
FIN

 

 

5.- Hallar la suma de los números enteros del 1 al 50

 

Inicio

        Numero = 1

        Suma  =  0

        Mientras Numero <= 50 hacer

                Suma = Suma + Numero

                Numero = Numero + 1

        Fin_mientras

        Escribir Suma

Fin

 

Este ejercicio presenta una novedad SUMA = SUMA  + NUMERO acá el  incremento no es de 1 en 1 si no de NUMERO en NUMERO se parece a un contador pero no se le llama contador el nombre de esta forma se le conoce como ACUMULADOR

Mientras los contadores acumulan de 1 en 1 los Acumuladores "ACUMULAN"  de N en N.

 

 

6.- Diseñar un algoritmo que me permita ingresar cualquier número  y luego el algoritmo deberá calcular los múltiplos menores que 100 del número ingresado.

Inicio

    Leer A

    Mult = A
    Mientras Mult <=100 hacer

         Escribir Mult

         Mult = Mult  + A

    Fin_Mientras
Fin

 

 

7.- Dado a, b determinar el valor de la división entera y el resto de la división entera de a, b
sin usar los operadores de DIV y MOD

Inicio
        Leer a,b
        cv = 0
        mientras a >= b hacer
                a = a - b
                cv = cv + 1
        fin_mientras
        pe = cv
        resto = a
        Escribir pe , resto
Fin

 

 8.- Mostrar solo la parte decimal de una división  entre 2 números a y b sin usar DIV y MOD

 

Inicio
        Leer a,b
        cv = 0
        mientras a >= b hacer
                a = a - b
                cv = cv + 1
        fin_mientras
        resto = a
        Valor_decimal = resto / b

        Escribe Valor_decimal
Fin

 

9.- Hacer un programa que calcule la suma, suma de cuadrados y suma de cubos de los N primeros números naturales.

Uso de variables:
cantidad de números naturales= num_n
suma= s
suma de cuadrados= s_cuad
suma de cubos= s_cub

        Inicio
            Leer num_n
                s = 0
                s_cuad = 0
                s_cub =  0

                n = 1
                Mientras  n <= num_n hacer
                        s = s + num_n
                        s_cuad = s_cuad + (n * n)
                        s_cub = s_cub + (n * n * n)
                fin_mientras
                Escribir s, s_cuad, s_cub
        Fin

 

Ejercicios Propuestos

 

1.- Hacer un programa que Muestre la tabla de multiplicar del número 5 sin mostrar el 25

      (Dentro del mientras habrá un SI FIN_SI)

2.- Hacer un programa que sume los 10 pares que le siguen al 24

3.- Hacer un programa que sume los 10 impares que le siguen al numero n

4.- Hacer un programa que sume los pares comprendidos entre 100 y 200 sin considerar el rango de números comprendidos entre

     50 y 76

5.- Hacer un programa que sume los 10 primeros números pares, luego que sume los 10 primeros Impares y muestre la diferencia de ambos resultados.

6.- Hacer un programa que sume los 10 números pares que le siguen a N, luego que sume los 10 Impares que le siguen a M y muestre la diferencia de ambos resultados.

7.- Hacer un programa que Muestre cuantos "Lunes" Hay entre las fechas 19 de Setiembre del 2004 y el 25 de diciembre del mismo año.

8.- Hacer un programa que Muestre cuantos "Lunes" Hay entre las fechas 19 de Setiembre del 2004 y el 25 de diciembre del mismo año, mostrando que día cae Lunes y el nombre del mes correspondiente de ese día.